Syncing issues
Incident Report for PullString, Inc
Resolved
This incident has been resolved.
Posted 10 months ago. Jul 21, 2017 - 16:04 PDT
Identified
We are currently experiencing intermittent syncing issues that have been identified and should be resolved within an hour.
Posted 10 months ago. Jul 21, 2017 - 14:18 PDT